quarta-feira, novembro 23, 2005

Frontend para a ligação Kanguru no Ubuntu 5.10

Este post é um substituto do post Kanguru no Ubuntu 5.04?
Este trata de instalar um frontend para ligação wvdial. As indicações abaixo apresentadas tornam desactualizadas as apresentadas no post acima referido. Apesar de tudo não deixam de ser verdadeiras.

Assim, a pergunta que fazemos é:

Como fazer uma ligação Kanguru, da Optimus, no Ubuntu 5.10?



1. É preciso do pacote kanguru o seguinte: a placa PCMCIA Merlin U530 e a parte restante do cartão que tem o número do utilizador e o pin;

2. Ligar o computador, no xterminal escrever tail -f /var/log/messages e de seguida connectar a placa na ranhura PCMCIA do portátil; no ecran deverá aparecer algo como:

Nov 23 01:40:36 localhost kernel: [4301663.577000] ttyS2 at I/O 0x3e8 (irq = 11) is a 16550A

Deverá aparecer algo semelhante a ttyS2, memorize.

3. Instalar o pacote gnome-ppp e as suas dependências;

4. Correr a partir do menu Applications->Internet->GNOME ppp;

5. Na janela GNOME PPP introduzir o Username (número telefónico do cartão), a Password (pin) e introduzir o número de ligação *99***1#. Clique em Setup.

Image hosted by TinyPic.com

6. Após ter clicado em Setup, na tab modem, escreva em Device o valor memorizado no ponto 2, no resto da janela coloque igual à imagem;

Image hosted by TinyPic.com

7. Pressionar o botão Init Strings... e preencher da seguinte forma:

Image hosted by TinyPic.com

Init 2: ATZ
Init 3: ATI
Init 4: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init 5: AT+CGDCONT=1,"IP","myconnection"
Init 6: At$NWRAT=0,2
Init 7: AT+CSQ

Pressione close e volte à janela anterior;

8. Na tab network, introduza os valores que se encontram na imagem abaixo apresentada;

Image hosted by TinyPic.com

9. Na tab options, introduza os valores que se encontram na imagem abaixo apresentada;

Image hosted by TinyPic.com

10. Clique em close e volte à janela do ponto 5. Pressione Connect. Já está!!!! Boas navegações.

6 comentários:

Tiago Manuel Sequeira disse...

não estou a conseguir ligar o meu modem 3G, é o Merlin U630 e quando faço para detectar dispositivo (imagem 6) colocando o código atribuido à porta PCMCIA onde no meu caso é ttyS0 quando faço detect nem o modem é reconheçido e no fim das configurações todas como aqui explicadas não consigo ligar-me que será qu se passa...?

Tiago Manuel Sequeira disse...

Quando faço connect aparece este registo de erro (depois de todas as configurações) :

--> WvDial: Internet dialer version 1.54.0
--> Cannot open ttyS0: No such file or directory
--> Cannot open ttyS0: No such file or directory
--> Cannot open ttyS0: No such file or directory

Tem alguma coisa a ver da minha placa ser uma Merlin U630 e não a U530?
Se sim como posso resolver este problema?

Agradecia a vossa ajuda se possivel.

Mr.776 disse...

ja agora e para a placa huawei e600? este howto tambem serve?

cumprimentos

Jose Reis disse...

saudaçoes.

Respondendo ao MR.776: para a placa Huawei e600 necessitas primeiro que actualizar o firmware, segundo instalares as driveres da placa.

no entanto tenho uma pergunta:
eu tenho a minha placa a funcionar....já tentei fazer a ligação utilizando wvdial e o gnome-ppp e recebo sempre....
--> Re-Sending: AT$NWRAT=0,2
AT$NWRAT=0,2
COMMAND NOT SUPPORT
--> Modem not responding.

sabes dizer pq?terá algo a ver com a actualização do firmware?!

Anónimo disse...

Para configurar a placa Huawei veja o link
http://fpm.dynu.com/index.php?option=com_content&task=view&id=105&Itemid=23

guilherme disse...

Eu adquiri uma merlin u740, pena que so agora vi este post e so consigo estar no windows :s se nao estou em erro pelo q tenho lido esta conf serve para a u740 mas com strings diferentes para se poder conectar em 3.5G, se alguem tive uma merlin u740 que deixe algum feedback, ja tou farto de usar windows :S